Capella Logo
Potential Login Services Interruption
Incident Report for Capella University
Resolved
This incident has been resolved.
Posted Aug 14, 2023 - 14:19 CDT
Update
We are continuing to investigate this issue.
Posted Aug 14, 2023 - 14:19 CDT
Investigating
Service disruptions have been detected with Capella's Login services for School A, C, and F.

Users may encounter issues when logging in or when attempting to log into Capella-hosted websites.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Aug 14, 2023 - 13:11 CDT
This incident affected: Login Services.