Capella Logo
Login Services Interruption
Incident Report for Capella University
Resolved
This incident has been resolved.
Posted Jan 01, 2024 - 11:38 CST
Identified
Service disruptions have been detected with Capella's Login services.

Users may encounter issues when logging in or when attempting to log into Capella-hosted websites due to a network-related issue.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Jan 01, 2024 - 11:34 CST
This incident affected: Login Services.