Capella Logo
Potential Campus Services Interruption
Incident Report for Capella University
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 04:00 CDT
Investigating
Service disruptions have been detected on the Capella Campus (Learner iGuide).

Users may encounter issues throughout the platform, which could include intermittent access to Course Dashboards, Capella Mail, Student Center or other Campus hosted services.

Faculty iGuide may also be impacted.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Jun 21, 2022 - 01:56 CDT
This incident affected: Campus (Dashboard, Capella Email, Academic Plan, Library Services, Competency Map, Readiness Center, Student Center).