Capella Logo
Potential Courseroom Services Interruption
Incident Report for Capella University
Resolved
This incident has been resolved.
Posted Mar 25, 2023 - 17:09 CDT
Investigating
Service disruptions have been detected within the Capella Courseroom.

Users may encounter issues when accessing their courses in the School of Business and Technology, School of Nursing and Health Sciences, Division of Arts and Sciences, and Undergraduate courses. The following features may be impacted: Assessments, Scoring Guides, or other Courseroom areas.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Mar 25, 2023 - 17:07 CDT