Capella Logo

CU Learners unable to access M365

Incident Report for Capella University

Resolved

There is a fix in place and CU Students are being processed and added back so they are able to access M365. This process will continue and restore students that need to be updated.
Posted Feb 12, 2025 - 16:02 CST

Identified

We have identified an issue that is causing some CU Learners to lose access to M365. Some CU Learners may not be able to login to M365. They are currently working on this issue.
Posted Feb 12, 2025 - 09:55 CST
This incident affected: Login Services.