Capella Logo
Capella Blogs currently unavailable
Incident Report for Capella University
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 09:09 CDT
Investigating
Capella Blogs currently unavailable
Posted Jun 20, 2022 - 20:02 CDT
This incident affected: Capella.edu (Main (rest of capella.edu)).