Capella Logo
Potential Student Information Services Interruption
Incident Report for Capella University
Resolved
This incident has been resolved.
Posted Mar 25, 2023 - 12:52 CDT
Investigating
Service disruptions have been detected with our Student Information Services system.

Learners may encounter issues when attempting to access billing, financial aid, course enrollment and registration materials or various other service interruptions.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Mar 25, 2023 - 12:39 CDT
This incident affected: Student Information Services (Enrollment Services, Financial Aid Services).